Lucid Motors Forum banner
21 - 24 of 24 Posts

· Registered
Joined
·
13 Posts
I have only used one EA station so far because it is close to my office. I pull up, plug in, it starts charging. I walk 50 steps to a Mexican Restaurant, eat a plate of Chili Colorado, and when I'm done the car is charged and I get an emailed receipt for $0.00...

...another owner I met has taken two cross-country trips and said he hasn't had any issues with charging. His only complaint is some EA stations are not in locations that are always convenient for personal pitstops. He said he has hung out in Walmart more in the last 5 months than in his whole life combined.
Interesting, thanks for sharing. I just charged at an EA station and had to use the "app workaround" method, but it did work. I also walked 50 steps to a Mexican restaurant, but had the Fajita Salad....

I'd like to talk to this cross country driver. While I haven't gone cross country, I did make a >1k mile round trip to LasVegas. And while I was always able to charge (so by one definition had no issues) I was still 0/5 attempts with Plug & Charge.

Now I'm 0/6.
 

· Registered
Joined
·
18 Posts
I'm wondering if the EA App is causing the problem? I only have the Lucid App and I don't have an EA account because it is not required. That is the only difference I can think of between your situation and mine. Maybe if you close the EA App or change the EA App settings to disconnect from Bluetooth temporarily and see if that resolves the issue.
 

· Registered
Joined
·
13 Posts
I'm wondering if the EA App is causing the problem?
You can't use the EA app with the Air -- it literally will not work (I've tried). So, I don't even open the EA app when I'm at their stations (unless I'm driving my wife's Ioniq 5 and trying to charge it).

I don't see how the car nor the EA station would even "know" I had the app if it isn't open on my phone.

One difference is I've only had the car a couple of weeks. It is possible that my car's VIN has been entered in to EA's database. I've also heard only some stations support Plug & Charge, so, that can also be the problem -- we are using physically different stations
 

· Registered
Joined
·
18 Posts
Good experience: Charged yesterday at EA. Pulled in, plugged into 150kw charger, charging started automatically. App said 45 minutes to complete. Went to lunch. 30 minutes later charging completed at 80%. Charging rate stayed above 127kw until the end and dropped to 81kw.
Font Gadget Screenshot Audio equipment Multimedia

Font Gadget Automotive lighting Circle Guitar accessory
 
21 - 24 of 24 Posts
Top